Online Banking Browser Update

Enhanced Security Notification

 In the upcoming months, the bank will be disabling the Transport Layer Security (TLS) protocol 1.0 and 1.1 on our web applications. Transport Layer Security (TLS) is a protocol that ensures that a connection to a remote endpoint is securely encrypted in order to provide privacy and data integrity. The banks web applications and application programming interface (API) connections use TLS as a key component of their security. TLS 1.2 is the most current version and is considered to be the most secure. This change will affect out web applications such as Retail Online Banking. 

As we enhance our security to align with industry requirements, you will need to verify if your operating systems (OS) or browsers support TLS 1.2 and upgrade if neccessary. If you do not have a compatible OS version or browser after we disable the old ones, you will get a connection error when attempting to access our online banking application.

Mobile Banking Users

Mobile banking users who are on older OS versions that do not support TLS v1.2, will need to upgrade their mobile OS version to be able to connect to Mobiliti through a TLS v1.2 connection. Mobile users who do not have a compatible OS version will get a connection error when attempting to access the Mobiliti platform. If issues are encountered, please upgrade your OS to:

Android: KitKat (Level 20) and above,

IOS: IOS 8 and above.

TLS Preparations

To prepare for this change, you will need to ensure that you are using operating systems and browsers that support TLS v1.2. Below is a basic TLS v1.2 compatibility chart. 

Browsers and Operating Systems TLS 1.2 Compatibility Notes
Microsoft Edge Compatible by default
Microsoft IE Desktop and mobile version 11 Compatible by default
Microsoft IE Desktop versions 9 and 10 Capable when you run in Windows 7 or newer, but not enabled by default
Firefox 27 and higher Compatible by default
Google Chrome 38 and higher Compatible by default
Mobile Safari versions 5 and higher Compatible by default
Microsoft Windows Server 2008 R2 and higher Compatible by default
Microsoft Windows Server 2008 and below Not Compatible with TLS 1.2
Microsoft Windows 7, 8.0 and 10 Compatible by default
Microsoft XP/Vista and below  Not Compatible with TLS 1.2